Cd-m.ru

ПК Журнал СД-М
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Создание кроссворда в программе Microsoft Excel

Создание кроссворда в программе Microsoft Excel

Кроссворд в Microsoft Excel

Многие люди любят разгадывать кроссворды, есть так же лица, которым нравится их составлять. Иногда, составить кроссворд требуется не просто ради развлечения, а, например, чтобы проверить знания учащихся нестандартным способом. Но, мало кто догадывается, что отличным инструментом для создания кроссвордов является программа Microsoft Excel. И, действительно, ячейки на листе данного приложения, как будто специально предназначены для того, чтобы вписывать туда буквы отгадываемых слов. Давайте выясним, как быстро составить кроссворд в программе Microsoft Excel.

Создание кроссворда

Прежде всего, нужно найти готовый кроссворд, с которого вы будете делать копию в программе Excel, или же продумать структуру кроссворда, если вы будете придумывать его полностью сами.

Для кроссворда нужны квадратные ячейки, а не прямоугольные, как по умолчанию в Microsoft Excel. Нам нужно изменить их форму. Для этого, на клавиатуре нажимаем комбинацию клавиш Ctrl+A. Этим мы выделяем весь лист. Затем, кликаем правой кнопкой мыши, чем вызываем контекстное меню. В нём кликаем по пункту «Высота строки».

Высота строки в Microsoft Excel

Открывается небольшое окошко, в котором нужно задать высоту строки. Устанавливаем значение 18. Жмем на кнопку «OK».

Установка высоты строки в Microsoft Excel

Чтобы изменить ширину, кликаем по панели с наименованием столбцов, и в появившемся меню выбираем пункт «Ширина столбца…».

Переход к изменению ширины столбца в Microsoft Excel

Как и в предыдущем случае, появляется окошко, в которое нужно внести данные. На этот раз это будет число 3. Жмем на кнопку «OK».

Ширина столбца в Microsoft Excel

Далее, следует подсчитать число клеточек для букв в кроссворде в горизонтальном и вертикальном направлении. Выделяем соответствующее количество ячеек на листе Excel. Находясь во вкладке «Главная», кликаем по кнопке «Граница», которая расположена на ленте в блоке инструментов «Шрифт». В появившемся меню, выбираем пункт «Все границы».

Установка границ в Microsoft Excel

Как видим, границы, очерчивающие наш кроссворд, установлены.

Установлены границы в Microsoft Excel

Теперь, следует удалить эти границы в некоторых местах, чтобы кроссворд принял нужный для нас вид. Это можно сделать при помощи такого инструмента, как «Очистить», значок запуска которого имеет форму ластика, и находится в блоке инструментов «Редактирование» всё той же вкладки «Главная». Выделяем границы ячеек, которые хотим стереть и кликаем на данную кнопку.

Кнопка очистить в Microsoft Excel

Таким образом, постепенно прорисовываем наш кроссворд, поочередно удаляя границы, и получаем готовый результат.

Кроссворд нарисован в Microsoft Excel

Для наглядности, в нашем случае, можно выделить горизонтальную строку кроссворда другим цветом, например желтым, воспользовавшись для этого кнопкой «Цвет заливки» на ленте.

Заливка желтым цветом в Microsoft Excel

Далее, проставляем номера вопросов на кроссворде. Лучше всего, это делать не слишком большим шрифтом. В нашем случае, использован шрифт 8.

Номера кроссворда в Microsoft Excel

Для того, чтобы разместить сами вопросы, можно кликнуть любую область ячеек в стороне от кроссворда, и нажать на кнопку «Объединить ячейки», которая находится на ленте всё на той же вкладке в блоке инструментов «Выравнивание».

Объединение ячеек в Microsoft Excel

Далее, в большой объединенной ячейке можно пропечатать, или скопировать туда вопросы кроссворда.

Вопросы кроссворда в Microsoft Excel

Собственно, сам кроссворд на этом готов. Его можно распечатывать, или разгадывать прямо в Экселе.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Таблица с результатами в Microsoft Excel

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

Вызов мастера функций в Microsoft Excel

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Мастер функций в Microsoft Excel

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Читать еще:  Как смотреть фильмы с компьютера на телевизоре

Переход к выбору ячейки в Microsoft Excel

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Выбор диапазона ячеек в Microsoft Excel

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Данные введены в Microsoft Excel

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Функция СТРОЧН в Microsoft Excel

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Функция ЕСЛИ в Microsoft Excel

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Автосумма в Microsoft Excel

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Ответ на кроссворд в Microsoft Excel

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

ЗакрытьМы рады, что смогли помочь Вам в решении проблемы.

Помимо этой статьи, на сайте еще 12369 инструкций.
Добавьте сайт Lumpics.ru в закладки (CTRL+D) и мы точно еще пригодимся вам.

Отблагодарите автора, поделитесь статьей в социальных сетях.

ЗакрытьОпишите, что у вас не получилось. Наши специалисты постараются ответить максимально быстро.

Как сделать интерактивный кроссворд?

Из этой статьи Вы узнаете, как создать кроссворд, используя возможности Excel. Мы создадим шаблон сетки кроссворда заполненный черными и белыми квадратами. Создадим определения для слов кроссворда используя комментарии, а так же создадим систему контроля проверяющую правильность записываемых при разгадывании кроссворда букв. Открываем Microsoft Excel и начинаем работать. Создаем новый документ и сохраняем его, например, под оригинальным названием «кроссворд.xls». Первое, что надо сделать, это превратить клетки из прямоугольников в квадраты. Наш кроссворд будет состоять из 10 строк и 10 столбцов. Выделяем мышью все ячейки диапазона между A1 и J10.

После того как выбраны ячейки, изменим их размеры. В находим пункт меню «Формат» и в подменю «Размер ячейки» выбираем пункт «Ширина столбца». В появившемся окне вводим значение 5. Затем жмем «Высота строки» и вводим значение 27. После этого выбранные ячейки будут выглядеть более квадратными.

Теперь у выделенных ячеек нарисуем границы. Используем для этого иконку «Границы» в панели инструментов. Жмем и в выпадающем меню, которое появляется, выбираем «Все границы». Все клетки кроссворда будут очерчены темными границами.

Теперь отформатируем ячейки кроссворда, для чего на первой ячейке щелкнем правой кнопкой мыши и в появившемся меню выберем пункт «Формат ячеек». В появившемся окне на вкладке «Выравнивание» установим значение Выравнивание по горизонтали и по вертикали в состояние – «по центру».

Заполняем кроссворд. Вписываем слова, а пустые ячейки заливаем черным цветом. Используем выпадающее меню «Цвет выделения текста». Жмем и выбираем цвет, например, черный. Но, вы можете выбрать любой, какой нравиться.

После того как кроссворд оформлен, слова записаны и блоки закрашены, подумаем о вопросах к словам. Для написания вопросов используем примечания. Это достаточно удобно, т.к. при выборе клетки для написания слова будет появляться всплывающее окно с примечанием, в котором написаны вопросы. Записываем вопросы, для чего выбираем ячейку, жмем правую кнопку мыши и в меню используем пункт «Вставить примечание».

Читать еще:  Антивирусы для MacOS

В появившемся окне вводим определения к словам. Вы можете изменить шрифт, размер, цвет и другие характеристики примечания. В случае если вопросы к словам есть по горизонтали и по вертикали, то введите оба определения, как показано на рис. Заполните примечания во всех ячейках, в которых необходимо разместить вопросы. Если увидите в верхнем правом углу маленький красный треугольник, значит там есть вопрос.

Чтобы отредактировать или удалить примечание для какой то ячейки, нажмите правую кнопку мыши на этой ячейке и в появившемся меню выберите пункт «Изменить примечание» или «Удалить примечание». Теперь необходимо удалить решения. Но, сначала, скопируем кроссворд в другую область листа. Выделим при помощи мыши весь кроссворд, как это делали в начале, жмем в меню пункт «Копировать» и переместившись вниз, например, в ячейку А35, нажимаем в меню пункт «Вставить». Таким образом, в области между А35 и J44 будет размещена копия кроссворда. При копировании потеряется форматирование размеров клеток, но это не страшно. Дальше вы поймете почему.

Теперь, вернемся к первому кроссворду и сотрем все буквы в клетках. Чтобы стереть все буквы быстро, выделим весь кроссворд и нажмем клавишу Delete. Теперь настроим проверку правильности букв, которые будет вписывать игрок, разгадывая кроссворд. Начнем с первой ячейки. Выбрав ячейку переходим к пункту меню «Условное форматирование» — «создать правило». В появившемся окне выбираем «Форматировать только ячейки, которые содержат» и задаем «значение ячейки» «равно» «=A35». Затем зададим изменение цвета ячейки при правильно записанной в нее букве. Жмем кнопку «Формат…» и выбираем цвет. После всех этих манипуляций жмем ОК. Ячейка отформатирована. Если вы попробуете вписать в нее букву, то при правильном ответе она станет зеленой. А при не правильном, цвет останется прежним.

Теперь скопируем формат этой ячейки во всех белые ячейки кроссворда. Жмем кнопку с кистью на стандартной панели инструментов и копируем формат в нужные ячейки.

Для предотвращения возможности игроку подсмотреть решение в скопированном ранее кроссворде, надо сделать его невидимым. Удалим из второго кроссворда все примечания, чтобы не было красных треугольников. Затем выделим мышью весь второй кроссворд и уберем границы ячеек, а шрифт и ячейки сделаем белого цвета. Но, чтобы не было видно содержимого в строке формул, даже если встать курсором на ячейку, сделаем следующее. Щелкнем по ячейке правой кнопкой мыши и в появившемся меню выберем пункт «Формат ячейки». В появившемся окне выбираем закладку «Число», в списке «Числовые форматы» выбираем «все форматы» и затем в поле «Тип» вводим три точки с запятой «;;;». Нажмем на кнопку OK. Содержимое всех ячеек станет невидимым. Теперь вы знаете, как сделать кроссворд на компьютере! Удачи!

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Есть люди, любящие разгадывать кроссворды, а есть, которые любят их составлять. В некоторых случаях он полезен, для проверки знаний учеников таким способом. Для таких целей Microsoft Excel самый лучший метод.

Начало конструирования кроссворда

Ищем готовый кроссворд или придумываем его сами. На его основе будет создаваться кроссворд на ПК.

1. Для его создания требуются квадратные клеточки, а не стандартные прямоугольники. Для этого следует поменять их форму. Используем сочетание кнопок Ctrl+A. Так мы выделили весь лист. Правая кнопка мышки позволяет нам вызвать дополнительное меню. В нем находим «Высота строки» и нажимаем на нее.

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

3. Для изменения ширины, нажимаем на название столбцов и нажимаем «Ширина столбца».

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

На этом создание кроссворда можно считать законченным.

Создаем автопроверку

В Экселе можно создать не просто кроссворд, а проверочный. В нем сразу будет видно, правильно ли ответили на вопрос или нет.
На новой странице приступаем к созданию новой таблички.

Столбец № 1 будет называться «Ответы». В него они и вписываются.

Столбец № 2 – отображает все ответы пользователя.

Столбец № 3 – «Совпадения».

Если ответ правильный, то появится цифра 1, если нет – 0. Здесь же можно создать отдельную клетку, в которой будет проставлена общее количество правильных ответов.

Читать еще:  Как перевести текст с фотографии в Ворд

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Как сделать кроссворд в Эксель

Теперь будет происходить преобразование любых символов в строчные. Аналогичные манипуляции проводим с каждой клеткой столбца «Введено» и соответствующей ей клеточками самого кроссворда.

Чтобы начать процесс сравнения, нужно применить значение «ЕСЛИ».

1. Выбираем клетку столбца «Совпадения».

2. Вводим следующее значение «=ЕСЛИ(координаты столбца «ответы»=координаты «Введено»;1;0).

3. В нашем примере «=ЕСЛИ(В3=А3;1;0)»

4. Все повторяем с другими клеточками «Совпадения». Клеточку «Итого» не трогаем.

Как сделать кроссворд в Эксель

Отмечаем все клетки в «Совпадении» вместе с «Итого» и нажимаем изображение автосуммы.

Теперь здесь будет выполняться проверочные действия, а итог отобразится в виде общей суммы.

Как сделать кроссворд в Эксель

Если нужно, чтобы итог увидел пользователь, опять применим «Если».

1. Возвращаемся на страницу с кроссвордом.

2. В ячейку начинаем вводить функцию согласно образца «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9; «кроссворд разгадан»; «Подумай еще»)».

Как сделать кроссворд в Эксель

3. На нашем примере это будет выглядеть так: «=ЕСЛИ(лист2!С12=9; «Кроссворд разгадан»; «Подумай еще»)».

Как сделать кроссворд в Excel

Эльвие Алимова 12.05.2015 12185 8

  • познакомить коллег с возможностями программы Excel;
  • Научить создавать кроссворды в программе Excel

Шаг 2.
Переименуйте свои листы.
Лист 1 – титульный лист
Лист 2 – кроссворд
Лист 3 – обработка результатов
Лист 4 – источники информации

Шаг 3.
Открываем лист «Кроссворд».
Выделяем несколько столбцов, например, от A до Z
Выбираем ширину столбца и высоту строки, для этого выбираем «Формат» — ширина столбца равную 3 и высоту строки равную 20.

Шаг 4.
Теперь мы должны заполнить ответы кроссвордов так, как они будут расположены в самом кроссворде.
Наберем первое слово «миристиновая» по горизонтали и рядом пишем вопрос
Таким образом, заполняем слова по вертикали и горизонтали

Шаг 5
Чтобы отобразить нумерацию в ответах нужно вставить примечания к начальным ячейкам
Например: миристиновая – рецензирование — создать примечание – пишем цифру 1.
При подведении мыши всплывает подсказка, что ответ относится к вопросу 1.
Точно также подписываете на остальных ответах

Шаг 6
Приступим к оформлению границ и заливки кроссворда для этого выделим слово «миристиновая» — нажмем клавишу Cntr и удерживая ее выделим остальные слова кроссворда.

Шаг 7
На ленте Главная. Выбираем Выравнивание и начинаем оформлять кроссворд.
Выравнивание – по центру по горизонтали и вертикали
Шрифт – Times New Roman, размер 12
Граница — внешние и внутренние
Заливка — выбираем цвет


Шаг 8
Можно вставить рисунки или картинки в Ваш кроссворд.
Для этого выбираете Вставка – рисунок – и выбираете рисунок с Вашего рабочего стола

Шаг 9
Поменяем фон листа. Для этого выбираем Разметка страницы – Подложка – Выбираем рисунок с Вашего рабочего стола и нажимаем на кнопку вставить

Шаг 10
Уберем сетку с кроссворда. Для этого на ленте вид – сетка – убираем галочку.

Шаг 11
Переходим на страницу Обработка результатов. Оформим страницы A и B ответами кроссворда.

После заполнения страницы A и B переходим к заполнению столбца С. Нам нужно слово сцепить. Для этого Нажимаем Формулы – Текстовые – выбираем слово «Сцепить».


В появившемся диалоговом окне текста 1 — перейдем на лист кроссворд и при нажатой клавише Cntr щелкаем по ячейкам, в котором находится первое слово и нажимаем на OK. В результате в ячейке появилось слово аналогичное нашему ответу. Таким образом, заполняем остальные ответы.

Шаг 12
После заполнения столбца С приступаем к заполнению столбца D. Мы должны проверить соответствуют ли слова в заполненных полях. Для этого воспользуемся логической функцией «если».
Выбираем Формулы – Логические – если – щелкаем по ячейке B2. Ставим = С2.

В значение истина ставим 1, а в значение ложь 0. Нажимаем OK.
Теперь воспользовавшись автозаполнением копируем на остальные ячейки. Для этого копируем ячейку и проводим на остальные ячейки.

Шаг 13
Заполняем титульный лист.
Пишем «У Вас верных ответов» и подсчитываем баллы. Рядом выбираем ячейку – сумма – выбираем страницу «Обработка результатов» и выделим все 1. Получилось 20.
Далее вставим текст «Ваша оценка» . Выбираем ячейку – функции – логические — если.
Если правильных ответов 18-20 оценка 5
Если правильных ответов 15-17 оценка 4
Если правильных ответов 12-14 оценка 3
Если G7>=18
Истина — 5
Ложь – 0

Теперь удаляем в строке формулы 0 и вставляем такую же функцию если для оценки 4, а далее для 3.

Шаг 14
На листе Источники информации записываете использованную литературу

голоса
Рейтинг статьи
Ссылка на основную публикацию
ВсеИнструменты
Adblock
detector